Vous avez une erreur lors de la construction d'un projet de nouvel espace de travail

? Harikrishnan @ | Original: StackOverFlow

Suis nouvelle pour le développement Android . Je ai essayé de créer un nouvel espace de travail avec SDK cible sous API 21 et compilé avec API 19. Je ai installé le SDK de API19 et 20 et non l' Android5 . Je ai créé un nouvel espace de travail et créé un nouveau projet dans lequel je ai fini avec l'erreur ci-dessous lors de la compilation du projet après l'avoir créé . Quelqu'un peut-il me aider à savoir comment se débarrasser de ce ?

Error details:



Top 5 Respuesta

1QArea @

Avez-vous changé l'objectif de construction du projet à Android 4.4.2 trop ?

Voici les gars avaient le même problème : http://stackoverflow.com/a/14843198/3864698



2Muhammad Ebad @

Un anthères chose que vous pouvez essayer est d'ouvrir le fichier project.properties de l'androïde -support- v7 - appcompat et changer la cible cible . Et puis il suffit de faire un projet - > Clean pour que les modifications prennent effet.

3Andy Dent @

Je ai eu une erreur similaire à quelqu'un de nouveau à l'installation d'outils Android et avoir tort sélectionné le 4.4W ainsi que 4.4.2 dans le Gestionnaire SDK Android .

Il en résulte ayant à la fois API 20 et 19 installé API qui signifie API 20 semble être plus récente et sera capté par défaut pour les nouveaux projets.

Cependant, API 20 est Wearables uniquement.

Vous pouvez voir ici dans Vous avez une erreur lors de la construction d'un projet de nouvel espace de travail que 4.4W a fini dans le chemin .

Tant le appcompat_v7 et les objectifs du projet HelloAndy eu ce problème de chemin .

Je ai édité project.properties à la fois pour et changé target = android- 20 à target = android- 19 a ensuite fait une actualisation sur les deux projets ( clic droit sur le appcompat_v7 et d'autres projets ) . Ce jour les chemins de construction pour pointer vers le SDK Android correcte .

4pokerface @

Mettre à jour le fichier des project.properties appcompat v7, qui a : target=android-19 à target=android-21

Également mettre à jour google play services bibliothèque ( par update Je veux dire mettre à jour dans «____» et réimportation etc )

5Adgaonker Shashank @

Il suffit de retirer cette ligne de style partout où l'erreur ne est trouvée, nettoyer votre projet

et faire de votre projet 5.0 paramétré