UnsupportedMethodException Android Studio 0.8.9

? user3184899 @ | Original: StackOverFlow

Je ai Android Studio 0.8.9 . Jusqu'à maintenant, ce pourrait synchroniser avec les fichiers Gradle succès , Mais aujourd'hui, quand je l'ai ouvert, il me donne cette erreur:

UnsupportedMethodException
         Failed to set up Android modules in project 'Project': Unsupported method: SourceProvider.getJniDirectories().
         The version of Gradle you connect to does not support that method.
         To resolve the problem you can change/upgrade the target version of Gradle you connect to.
         Alternatively, you can ignore this exception and read other information from the model.

Pouvez-vous me aider à résoudre ce problème? Merci .



Top 5 Respuesta

1Danuofr @

Pour corriger ce problème, je déclassé l'androïde -plugin dans vos projets haut de fichiers build.gradle niveau de     classpath ' com.android.tools.build:gradle:0.14.+ ' à     classpath ' com.android.tools.build:gradle:0.13.+ '

Donc maintenant la méthode de buildscript dans mes projets build.grade ressemble

buildscript {
  repositories {
    mavenCentral()
  }
  dependencies {
    // NOTE: Do not place your application dependencies here; they belong
    // in the individual module build.gradle files
    classpath 'com.android.tools.build:gradle:0.13.+'
  }
}

Je pense qu'il peut y avoir un bug avec la version 0,14, je ai envoyé mon rapport d'erreur .



2Jeff Brateman @

Comme l'a déclaré http://stackoverflow.com/questions/26680972/unsupportedmethodexception-android-studio-0-8-9#comment42031754_26692486, Mise à niveau vers Android 0.9.0 studio corrige ce problème .